Open AI - Warning: 403

With open AI APIs. Regardless of the type selected, I always get the same message. Is this not the fault of the software?

Are you using vpn/proxy?

https://platform.openai.com/docs/guides/error-codes/api-errors

https://platform.openai.com/docs/supported-countries

NO. I don’t use a proxy, I have my own IP. It stopped working after updating Kontent machine, old projects don’t work either

Can you switch it to ‘scm ai’ and see if it works?

image

Error does look like a region ban of your IP by open ai, not specifically a SCM thing

Running on my side so far.

I changed my IP to a new one, added Open AI and wrote in chat, everything seems to work. Now I run Kontent Machine and immediately I get a 403


After stopping the project after 1 check, I see that there is still already a 403 error even in chat. I ran another program added API to OPEN AI to see if it blocks IP. Everything works

When I restart the apps Content Machine, the chat works again! To me it looks like some kind of bug in the program,

https://platform.openai.com/docs/guides/error-codes/api-errors

According to openai it’s blocking access due to your ip address.

If you are using VPN to change ip it might work.

But right now ip based ban.

Why it happens sometimes and not others is weird.

Can you go settings backup and zip SCM and send me backup?

Maybe I can see what is going on.

SCM should be using your bare pc ip address to make calls.

Also try SCM ai

Finally you could try groq AI as backup.

Looks like many other users having this problem

Maybe even vpns might not help.

This is openai error, maybe their detection software isn’t working well.

The only thing SCM can do is proxy the requests and hope that the ip change can Bypass.

Would require testing.

I did a test.
I created a brand new account in Open AI, generated an API key , added to Zennoposter to see if it works, added to KM - chat works, turned on the project is error 403, started Zennoposter Open AI works, in KM does not work, reset KM chat works, turned on the project does not work. Ok I give up.

Thankyou for that info.

My guess is the calling code that reaches out to openai is slightly different in chat window vs running a task.

In a tasks cases openai to trip up.

Once you run task and it fails, does chat window stop working as well?

Yes the window also stops working. Yes the window also stops working, but when I reset the KM then the chat window works!

It’s weird that resetting it would work all of a sudden.

Must be some sort of tracking or caching in the requests.

I have a slightly older version of SCM here:

https://u.pcloud.link/publink/show?code=XZ8gus0ZMb4Whugtk05sJwBzS2lklJhmDQz7

Can you download it and see if it solves all your issues?

This is how this version works

Previously, everything worked for me. When I uploaded the latest version this problem appeared. The old version you gave me works

I have released a new update to SCM

Please download and give it a test to see if it works better now.

In the backend I redid the code that connects to external services and hoping this new method will make all calls standardized.