Google maps - Not scraping results - https://consent.google.com/

Problem:

When running Google maps it doesn’t provide results.

Investigation:

When viewing task log you see lots of urls starting with

https://consent.google.com/m?continue=

Eg

6/11/2024, 7:48:24 PM 1 of 1 done - consent.google.com
6/11/2024, 7:48:22 PM 1 of 1 looking for email at https://consent.google.com/contact-us (404) …
6/11/2024, 7:48:18 PM 1 of 1 looking for email at https://consent.google.com/contact (404) …
6/11/2024, 7:48:12 PM 1 of 1 looking for email at https://consent.google.com
6/11/2024, 7:48:06 PM 1 of 1 visit https://consent.google.com/m?continue=https://www.google.com/maps/s
6/11/2024, 7:48:06 PM Using 5 task threads
6/11/2024, 7:48:05 PM Found 1 places
6/11/2024, 7:48:04 PM Got direct location Google Maps
6/11/2024, 7:48:01 PM Going to map Google Maps

Solution

If this is happening to you
You need to open Google maps in SCM and click Accept on consent warnings.

Open Dynamic scraper > paste in consent url

Click Accept

As long as you don’t clear cookies it will remember the setting

You might need to do this for different proxies

I will also add a auto clicker for this button in newer versions of SCM.

1 Like